はじめに

 Simple Remote - 【はじめに】

◆動作環境とご利用上のご注意

＜対応OS＞

サーバー ： Windows 2000、XP
クライアント ： Windows 98、Me、NT4(SP6)、2000、XP、2003 Server

※本ソフトウェアでは「操作する側」がサーバー、「操作される側」がクライアントになります。

＜ご利用条件および注意事項＞

・このソフトウェアの著作権は、有限会社デジ・デジ・デイが所有します。
・本製品の使用によって生じた損害に関して、著作者は責任を負いません。
・本製品を改造して使用することを禁止します。
・このソフトウェアおよびこのドキュメントの内容を無断で転載することはできません。
・このソフトウェアはシェアウェアです。継続してご使用になる場合には、ユーザー登録を行っていただく必要があります。

※以上の条件に同意されない場合には、本製品を使用することができません。

◆概要と特徴

  『Simple Remote』は、弊社のビジネス顧客サポートの要求に基づいて開発された文字通りシンプルなPC遠隔操作用のソフトウェアです。インターネット経由で遠隔地にあるPCの画面を表示し、マウス操作やキーボード操作、ファイル転送を行うことができます。簡単な設定と準備を行うだけで、すぐに顧客や家族、友人・知人などのPCトラブルのサポートにご活用いただけます。

＜主な特徴＞

・ 操作される側（クライアント）から操作する側（サーバー）へ接続するので、操作される側がルーターを介していたり、操作される側のIPが変わっても特別な設定をすることなく接続が可能。
・ 機能がシンプルなため、操作や設定が簡単でサポートに集中できる。
・ サーバー、クライアントともにインストール不要でファイルサイズが非常にコンパクト。クライアントは50KB程度のプログラム（EXEファイル）1つだけ。
・ クライアント毎のソフトウェア費用が必要ないので低コスト。


＜ユーザー登録について＞

◆はじめに

・『Simple Remote』はシェアウェアです。継続してご使用になるにはユーザー登録を行い、ライセンスキーを取得していただく必要があります。

・ユーザー登録は、サポートや今後のバージョンアップを保証するものではありません。現在のバージョンをご試用いただき、その機能や操作感などにご納得の上でユーザー登録を行ってください。

◆ライセンスについて

・ライセンスを取得された場合、１ライセンスにつき１台のコンピュータにインストールして使用することができます。

◆ライセンスの取得方法

・ライセンスの取得方法は、下記のアドレスをご参照ください。

 http://www.digidigiday.com/digidigi/dgbrand/srmt/regi.html

◆その他ライセンスに関してご不明な点は下記メール宛にご質問ください。

reg-user@digidigiday.com


クイックリファレンス

 Simple Remote - 【クイックリファレンス】

  １．接続概念図

  ２．ネットワーク構成パターン

  ３．画面解説

  ４．操作説明

  ５．接続までの流れ


接続概念図

 Simple Remote - 【クイックリファレンス-接続概念図】

『Simple Remote』では操作される側から操作する側へ接続を行います。
そのためクライアントプログラムはサーバー（操作する側）のアドレスを知る必要があります。
クライアントプログラムがサーバーのアドレスを知るためには下図中のように「①」～「③」の３つ方法があります。

［Simple Remote接続概念図］


ネットワーク構成パターン

 Simple Remote - 【クイックリファレンス-ネットワーク構成パターン】

『Simple Remote』では、以下のようなネットワーク構成での接続に対応しています。

操作される側（クライアント）が操作する側（サーバー）に接続するため、操作する側がルーターを設置している場合、「ポートフォワード」、「ＤＭＺ」といった（操作する側の）ルーターの設定を行う必要があります。
※設定が必要になる具体的な例は下図中パターン４、５を参照下さい。

○パターン１：LAN内部で（プライベートＩＰ同士）の接続

［ＬＡＮ内部での接続］

○パターン２：グローバルＩＰ同士の接続

［グローバルＩＰ同士］

○パターン３：クライアント側がルーターを設置している場合の接続

［クライアント側がルーターを設置］

○パターン４：サーバー側がルーターを設置している場合の接続

［サーバー側がルーターを設置］

○パターン５：クライアント、サーバー共にルーターを設置している場合の接続

［クライアント、サーバー共にルーターを設置］


サーバーアドレスの取得方法

 Simple Remote - 【クイックリファレンス-サーバーアドレスの取得方法】

『Simple Remote』では、クライアントプログラム（操作される側）からサーバープログラム（操作する側）へ接続を行うため、「サーバーアドレス」をクライアントプログラムが何らかの方法で取得する必要があります。
クライアントプログラムがサーバーアドレスを取得するには、次の３つの方法があります。

①操作される側のユーザーが入力する

②クライアントプログラムに埋め込む

③Webから取得する

①サーバーアドレスを操作される側のユーザが入力

クライアントプログラム起動時に、「ＩＰ」、「ポート」が空の状態になっています。
サーバーアドレスをクライアントプログラム使用者に伝える必要があります。

〈利点〉

・サーバーアドレスが変動した場合でも、毎回クライアントプログラムを生成・配布する必要がありません。

②サーバーアドレスをクライアントプログラムに埋め込む

クライアントプログラムを起動すると、サーバープログラムでクライアントプログラム生成時に埋め込まれた「ＩＰ」、「ポート」が初期値として表示されます。

〈利点〉

・サーバーアドレスに変更がない場合、クライアントプログラムに埋め込まれた「ＩＰ」、「ポート」で直ちに接続を行うことができます。

③サーバーアドレスをWebから取得する

クライアントプログラムは、サーバープログラムでクライアントプログラム生成時に埋め込まれた「Webアドレス」から「ＩＰ」、「ポート」の取得を行います。

このようにWeb上で公開するサーバーアドレスを『Web公開アドレス』と呼びます。

〈利点〉

・Web公開アドレスを更新することにより、サーバーアドレスが変動した場合でもクライアントプログラムは自動で最新の情報を取得できます。

◆Web公開アドレスの仕組み

サーバープログラムは、Web公開アドレスの更新によって指定した「ＩＰ」、「ポート」が記載されたテキストファイルを作成し、Web領域の指定したパスへＦＴＰ経由でアップロードします。
クライアントプログラムは、サーバープログラムによってアップロードされたWeb公開アドレスをＨＴＴＰ経由で自動的に取得します。


接続までの流れ

 Simple Remote - 【クイックリファレンス-接続までの流れ】

◆接続までの流れ

１．環境設定 ［サーバー］

主に接続に使用するポートを設定します。
※参照…サーバーメニュー：環境設定

        ↓

２．クライアントプログラム生成 ［サーバー］

クライアントに配布するためのプログラムを生成します。
※参照…サーバーメニュー：クライアントプログラム生成

        ↓

３．（必要に応じて）Web公開アドレス更新 ［サーバー］

２．でWeb公開アドレスから取得するタイプのクライアントを生成した場合、Web公開アドレスの更新を行います。
※参照…サーバーメニュー：Web公開アドレス更新

        ↓

４．クライアントプログラムの配布

メールや各種ディスクメディアなどによる配布、またはWebからダウンロード（および実行）できるように準備を行います。
クライアントプログラムは、配布に便利なように非常にコンパクトに設計されています。

        ↓

５．接続の待ち受け ［サーバー］

クライアントからの接続を待ち受けます。
※参照…サーバーメニュー：接続を待ち受ける

        ↓

６．クライアントプログラムから接続 ［クライアント］

クライアントプログラムから接続を試みます。
※参照…クライアント：接続

        ↓

７．クライアントプログラムからの接続要求の受け入れ ［サーバー］

クライアントから接続要求があると、接続を受け入れるかどうかの確認メッセージが表示されます。
メッセージ内に表示されているクライアント情報を参考にして認証を行います。

［接続受け入れの確認］

【IP】：クライアントＰＣのＩＰアドレスが表示されます。

【コンピューター名】：クライアントＰＣのコンピューター名が表示されます。

【ユーザー名】：クライアントＰＣのユーザー名が表示されます。

【識別情報】：クライアントプログラム生成時に設定したクライアント識別情報が表示されます。
※参照…サーバーメニュー：クライアントプログラム生成

接続要求を受け入れるとクライアントとの接続が開始されます。


操作と接続までの流れ

 Simple Remote - 【クイックリファレンス-リモート操作とファイル転送】

◆画面解説

以下はクライアントと接続された時のサーバープログラムの画面（例）です。

［サーバープログラム画面］

サーバープログラムは、各機能を提供するメニューバー部分と、クライアントの画面を表示する部分のみのシンプルな画面構成となっています。
※メニュー部分に関してはこちらを参照ください。
  サーバーメニュー　・　クライアントメニュー　・　ヘルプメニュー

画像中で「クライアントの画面」 となっている赤枠部分は、接続先ＰＣの画面表示領域です。
クライアントプログラムとなっている部分は、接続先ＰＣ上で動作しているクライアントプログラムです。

◆操作説明

○クライアント画面表示領域にてマウスを動かしたり、キーを押すことにより接続先のＰＣを操作することが可能です。

○クライアントＰＣの画面解像度がサーバー側の解像度より大きく全て収まらない場合は、上図のようにスクロールバーが表示されます。

○最大化ボタンのクリック、タイトルバーのダブルクリックにより、現在のサーバープログラムウィンドウの位置から可能な限りでウィンドウ枠を広げます。

◆ファイル転送

○クライアント画面表示領域にファイルをドラッグ＆ドロップすると、クライアントＰＣのデスクトップ上に対象のファイルが転送されます。

○クライアントＰＣで動作しているクライアントプログラムウィンドウにファイルをドラッグ＆ドロップすると、サーバー側ＰＣのデスクトップ上に対象のファイルが転送されます。

※同時に転送できるファイルは１つです。


サーバープログラム

 Simple Remote - 【サーバープログラム】

  １．サーバーメニュー

  ２．クライアントメニュー

  ３．ヘルプメニュー


サーバーメニュー

 Simple Remote - 【サーバーメニュー】

［サーバーメニュー］

「メニューバー」から【サーバー】を選択すると上図のようなメニューが表示されます。

１．接続を待ち受ける

２．環境設定

３．クライアントプログラム生成

４．Web公開アドレス更新

５．終了

◆サーバーメニュー -> 接続を待ち受ける

クリックすることで、クライアントからの接続の待ち受けを開始します。

［接続待ち受け中の画面］

待ち受け開始時には、上図のように 「タイトルバー」に”[接続を待ち受け中(指定したポート番号)]”というメッセージが表示されます。
その際、表示されるメニューにはチェックが入ります。
再度クリックすることにより、待ち受けを終了します。

※【環境設定】により、プログラム起動と同時に待ち受けを開始することができます。

◆サーバーメニュー -> 環境設定

【環境設定】を選択すると下図のような画面が表示されます。

［環境設定画面］

①待ち受けポート番号

クライアントとの接続に使用するポート番号を指定します。
ポート番号の有効な範囲は「0～65535」ですが、一般的に使用可能な範囲は「1024～65535」とされています。
※「1024～49151」はレジスタードポート番号と呼ばれIANAにより番号の予約や使用状況の公表が行われていますが、動作に支障がない限り自由に使用しても問題ありません。

②プログラム起動と同時に待ち受けを開始する

ここをチェックすることで、プログラム起動時に直ちに待ち受けを開始します。

［チェックされた場合］

③サーバーに割り当てるALTキー

クライアントに対する操作ではなく、メニューバーの選択時などでサーバープログラムへの操作のために割り当てるALTキーを選択します。

［割り当てのリスト］

例として、サーバーに割り当てる【Alt】キーを「左のみ」を設定した場合、
・【左Alt】キー＋【T】キーでは、サーバープログラムのクライアントメニューにあるテキスト入力のウィンドウが表示されます。
・【右Alt】キー＋【T】キーでは、クライアントＰＣにキー入力の情報が送られます。（動作は使用中のアプリケーション等により変わります）
以上のように【Alt】キーを交えた動作が変わります。

◆サーバーメニュー -> クライアントプログラム生成

［クライアントプログラム生成画面］

①アドレスはユーザーが手動で入力する

この項目を選択した場合は、サーバープログラムとの接続の際に、クライアントプログラム使用者が直接アドレスを入力して使用することになります。

②アドレスの初期値を指定する

この項目を選択した場合、指定した値がクライアントプログラムに初期値として設定されます。（①と同様に入力も可能）

【IP】
  - 「IP」にはサーバープログラムと接続するために必要なIPを設定します。
    入力された値は、次回からの初期値として採用されます。

    ※サーバープログラム使用者の環境が固定IPでない場合、IP変動の結果、クライアントプログラムに指定された値が無効になってしまう点にご注意ください。

・IPのリスト
  - リスト中にある値は、使用中のＰＣに現在割り当てられているIPです。
    また、 「ルータ越えIPの取得」を選択すると、サーバープログラムがルータを介している場合に、外部への接続に使用される「IP」を取得することができます。

［IPをリストから選択］

【ポート】
  - 「ポート」には【環境設定】で指定された値が初期値として入力されます。
    必要に応じて任意の値を入力してください。

    参照…環境設定

③アドレスはWeb公開アドレスから取得する

この項目を選択した場合、Web上の参照可能なテキストデータから、アドレスを自動取得します。

［入力例］

参照…Web公開アドレス更新

④クライアント識別情報

任意の値を入力することができます。
クライアントプログラムから接続要求がありクライアント情報が表示される際に、ここに入力された値が識別情報として表示されます。

◆サーバーメニュー -> Web公開アドレス更新

［Web公開アドレス更新画面（入力例）］

①IP・ポート

ここに入力された「IP」、「ポート」の値がテキストファイルとして、ＦＴＰ設定で指定されたパスにアップロードされます。

［IPをリストから選択］

【IPのリスト】

  - リスト中にある値は、使用中のＰＣに現在割り当てられているIPです。
    また、 「ルーター越えIPの取得」を選択すると、サーバープログラムがルータを介している場合に、外部への接続に使用される「IP」を取得することができます。

【ポート】
  - 「ポート」には【環境設定】で指定された値が初期値として入力されます。
    必要に応じて任意の値を入力してください。

    参照…環境設定

②ホスト

FTPサーバーに接続するためのホスト名を入力します。

③PASVモード

FTP接続をPASVモードで実行する場合は、ここをチェックします。

④ファイルパス

ファイル名を含めたルートからの保存先を指定します。

保存先および使用するファイル名は任意ですが、運用上支障のないようご注意ください。
ファイル名に関しては、特別な事情がない限り拡張子を「.txt」とすることをお薦めします。

⑤ユーザー名

FTPサーバーに接続するためのユーザー名を入力します。

⑥パスワード

FTPサーバーに接続するためのパスワードを入力します。

◆サーバーメニュー -> 終了

プログラムを終了します。
また、その際にはクライアントとの接続が解除されます。


クライアントメニュー

 Simple Remote - 【クライアントメニュー】

［クライアントメニュー］

「メニューバー」から【クライアント】を選択すると上図のようなメニューが表示されます。

１．切断

２．テキスト入力

３．次回自動的に接続する

◆クライアントメニュー -> 切断

クライアントとの接続を終了します。
クライアントの切断ボタンを直接押したり、【Shift】キー＋【Esc】キーでも切断可能です。

※改めてクライアントからの接続要求がない限り、サーバー側から接続することはできません。

◆クライアントメニュー -> テキスト入力

【テキスト入力】を選択すると下図のようなテキスト入力用のウィンドウが表示されます。

［テキスト入力ウィンドウ］

クライアント側のアプリケーションに対してテキストを一括で入力する際に使用します。
『OK』ボタンを押すと、テキストボックスに入力された文字がクライアントに送信されます。
サーバープログラム上で直接キーをタイプしてもクライアントに対して文字を入力することができますが、クライアントのレスポンスが良好でない場合や大量の文字を送る場合、またサーバーでコピーした文字をクライアントに対して送る場合など、様々な状況で活用することができます。
※アプリケーションによっては動作しない場合があります。

◆クライアントメニュー -> 次回自動的に接続する

クリックすると、クライアントＰＣが次に起動した際に自動的にクライアントプログラムを起動し、サーバーと接続を試みるように設定します。

［チェックされたメニュー］

その際、クライアントプログラムのタイトルバー上に「次回自動接続」と表示され、設定が行われたことを確認することができます。

［自動接続を設定されたクライアントプログラム］

操作の内容によってクライアントＰＣを再起動する必要があり、（接続が切れるため）再度接続が必要な際などに役立ちます。

※１：意図しない自動実行を防止するため「次回自動接続」と表示されている場合でも、クライアント側を手動で終了した場合には「次回自動接続」が有効になりません。
※２：再起動後ログイン画面が出る場合や、ダイアルアップ等で接続画面が出る場合、接続するためにはクライアント側の操作が必要になります。


ヘルプメニュー

 Simple Remote - 【ヘルプメニュー】

［ヘルプメニュー］

「メニューバー」から【ヘルプ】を選択すると上図のようなメニューが表示されます。

１．ヘルプ

このヘルプを開きます。

２．デジ・デジ・デイのホームページを開く

弊社のホームページを開きます。
本プログラムに関する最新バージョンの公開やお知らせをいたします。

３．バージョン情報

本プログラムのバージョン等の情報が表示されます。


クライアントプログラム

 Simple Remote - 【クライアントプログラム】

１．クライアントプログラムの種類と接続の方法

２．接続の終了（切断）

◆クライアントプログラムの種類と接続の方法

クライアントプログラムは、サーバープログラムから生成される時点で大きく３つのタイプに分かれます。

①アドレスをユーザーが入力するタイプ

②アドレスの初期値が入力されたタイプ

③アドレスをWebから取得するタイプ

接続に必要な操作は、起動後に接続ボタンをクリックするだけです。
※アドレスをユーザーが入力するタイプの場合はアドレス・ポートの入力が必要です。

◆アドレスをユーザーが入力するタイプ

アドレス、ポートをクライアントプログラムを使用するユーザーが入力します。
事前にこれらの情報をユーザーに知らせる必要があります。

［アドレスをユーザーが入力するタイプ］

※参照…操作方法（サーバー編）-サーバーメニュー：クライアントプログラム生成

◆アドレスの初期値が入力されたタイプ

クライアントプログラム生成時に入力された値が初期値として表示されています。
ユーザーは接続ボタンをクリックするだけでサーバーと接続することが可能です。
※必要に応じて初期値として入力された値を変更して使用することも可能です。

［アドレスの初期値が入力されたタイプ］

※参照…操作方法（サーバー編）-サーバーメニュー：クライアントプログラム生成

◆アドレスをWebから取得するタイプ

Web上で公開されたアドレスを取得し、接続を行います。
サーバーのＩＰアドレスが変更された場合や、ポートに変更があった場合などでもWeb上のアドレスを常に最新の状態にすることにより、クライアントプログラムは柔軟に対応することができます。

［アドレスをWebから取得するタイプ］

自動取得の場合は、クライアントプログラム生成時に設定されたWebアドレスからＩＰ、ポート番号の取得を行います。

［アドレスの取得］

※参照…操作方法（サーバー編）-サーバーメニュー：クライアントプログラム生成

◆接続の終了（切断）

サーバーとの接続を終了する場合、

１．切断ボタンをクリック

２．[Shift]キー＋[Esc]キー

３．「×」ボタンのクリック
※この場合、切断後直ちにウィンドウを閉じます

以上のいずれかの操作により、切断を行います。

［サーバーと接続中のクライアントプログラム］

また、サーバープログラム側から切断を行った場合や、サーバープログラムを終了した場合にも切断されます。